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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to analyze an HFSS project, calculate surface losses, and create
and solve an Icepak design based on the same geometry.

This chapter contains the following topic:

l "Sample Project - TheWaveguide Filter" below

Sample Project - The Waveguide Filter
In this project, you will learn how to import the waveguide filter model. HFSS calculates the RF
losses in the waveguide, and Icepak solves for thermal fields.

Figure 1-1: Waveguide Filter

Getting Started with Icepak: Waveguide Filter
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2 - Run the HFSS Simulation
This chapter contains the following topic:

l Open the Project
l Review the HFSS Design
l Analyze the HFSS Design and Report Losses

Open the Project
This chapter contains the following topics:

l Launch the Ansys Electronics Desktop

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the fileWaveguide_Filter_HFSS.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Figure 2-1: Waveguide filter model in the 3D Modeler window

Getting Started with Icepak: Waveguide Filter
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3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

3. ClickOK.

Review the HFSS Design
1. In the history tree, expandModel > Solids > Aluminum and review the component geo-

metry.

Run the HFSS Simulation 2-2
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Figure 2-2: History tree

2. From the HFSSmenu, select Fields > Edit Sources to review the sources.

Figure 2-3: Edit post process sources dialog box

Note: Port 1 is excited by 50W.

3. Click Cancel to close the Edit post process sources dialog box.
4. In the Project Manager, expand Definitions>Materials and double-click on aluminum to

open the View/Edit Material dialog box.
5. Enable All Properties to view the material properties used in electromagnetic, thermal,

and structural simulations.

Run the HFSS Simulation 2-3
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6. Click Cancel to close the dialog box.

Analyze the Design and Report Surface Losses
1. In the Project Manager, expand Analysis.
2. Right-click on the solution setup (Setup1) and select Analyze to run the HFSS simulation.
3. Right-click Setup1 and select Convergence.
4. Change the View to Plot and review the convergence statistics in the convergence table

and plot.

Note:When the simulation is complete, a message is displayed in theMessage Manager
indicating normal completion.

Run the HFSS Simulation 2-4
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5. After the simulation is complete and you're finished reviewing the convergence statistics,
click Close.

6. In the history tree, select wg_flange_in, wg_flange_out, and wg-outer.
7. On theModel ribbon, click New object List to create an object list to be used in the Fields

Calculator.Objectlist1 appears under Lists in the history tree.

Figure 2-4: History tree - Objectlist1

8. From the HFSSmenu, select Fields > Calculator to open the Fields Calculator.
9. Under Input, clickQuantity and select SurfaceLossDensity.
10. ClickGeometry, select Surface, selectObjectlist1, and click OK.

11. Under Scalar, click Integrate ( ).
12. UnderOutput, click Eval. The surface loss is calculated.

Note: The EM loss is displayed in Watts.

Run the HFSS Simulation 2-5
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Figure 2-5: Fields Calculator

13. Verify the results and click Done to close the Fields Calculator.

Run the HFSS Simulation 2-6
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14. From the Filemenu, select Save.

Run the HFSS Simulation 2-7
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3 - Prepare and Run the Icepak Sim-
ulation

This chapter contains the following topic:
l Set Up the Icepak Design
l Assign Thermal Boundary Conditions
l Set Solution Type
l Define Design Settings
l Add a Solution Setup
l Generate a Global Mesh
l Generate the Refined Mesh

Set Up the Icepak Design
1. In the history tree, right-clickModel and select Select All.

2. From the Editmenu, select Copy. Alternatively, you can press Ctrl + C to copy the geo-
metry.

3. From the Projectmenu, select Insert Icepak Design.

Getting Started with Icepak: Waveguide Filter
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Figure 3-1: Project Manager

4. Right-click in the 3D Modeler window and select Edit > Paste. The geometry from the
HFSS design is inserted into the Icepak design. Alternatively, you can press Ctrl + V to
paste the geometry.

5. On the Draw ribbon, click Fit All. Alternatively, you can press Ctrl + D to fit the geometry.

Figure 3-2: Draw ribbon - Fit All

Prepare and Run the Icepak Simulation 3-2
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Figure 3-3: Waveguide Filter Geometry in Icepak Design

Note: The Region geometry (computational domain) is automatically created.

6. In the history tree, right-click air and select Properties to examine the thermal material
properties.

7. Change the material to fluid air by selecting Air(@300K) and clickingOK.

Prepare and Run the Icepak Simulation 3-3
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Figure 3-4: Select Definition dialog box

8. To ensure that the appropriate geometry is included in the analysis, select wg_outer, wg_
flange_in, and wg_flange_out in the history tree and ensure that Solve Inside is enabled
in the Properties window.

Figure 3-5: Properties window - wg_outer

Assign Thermal Boundary Conditions
Assign the Inlet Opening

1. Press F to enter face selection mode.

Note:When selecting faces, you can press the B key to select the face immediately
behind your initial selection.

2. In the 3D Modeler window select the min Y side of the Region geometry.

Prepare and Run the Icepak Simulation 3-4
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Figure 3-6: Min Y side of Region geometry

3. Right-click in the 3D Modeler window and select Assign Thermal > Opening > Free.
4. Enter Inlet as the Name.
5. Under Flow Specification, select Velocity for Inlet Type.
6. For Y Velocity, enter 1 and retain the unit asm_per_sec.
7. Click OK.

Prepare and Run the Icepak Simulation 3-5
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Assign the Outlet Opening
1. In the 3D Modeler window select the max Y side of the Region geometry.

Figure 3-7: Max Y side of Region geometry

2. Right-click in the 3D Modeler window and select Assign Thermal > Opening > Free.
3. EnterOutlet as the Name.
4. Retain the default settings and click OK.

Assign the EM Surface Loss
1. In the history tree, select wg_flange_in, wg_flange_out, and wg_outer using the Shift key.

Prepare and Run the Icepak Simulation 3-6
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Figure 3-8: History tree - EM loss selection

2. Right-click in the 3D Modeler window and select Assign Thermal > EM Loss.
3. In the Setup Link dialog box, select the Use This Project check box.
4. On the Variable Mapping tab, click Map Variable by Name to compare the source

design variables to the Icepak design variables. Any variables with the same name are
mapped so that the source design conforms to the Icepak design.

5. ClickOK.
6. In the EM Loss dialog box, enter SurfaceLoss as the Name.
7. Ensure the wg_flange_in, wg_flange_out, and wg_outer are listed under Surface. If they

are not, drag them under Surface to designate a surface loss.
8. ClickOK.

Figure 3-9: Project Manager - Thermal Boundary Conditions

9. From the Filemenu, select Save.

Set Solution Type
Specify the design’s solution type as follows:

1. Click Icepak>Solution Type.

The Solution Type dialog box appears.

2. Ensure that Steady State and Temperature and Flow are selected and clickOK.

Prepare and Run the Icepak Simulation 3-7

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak: Waveguide Filter

Figure 3-10: Solution Type

Create a Point Monitor
To check the temperature of a specified point during a solution, create a point and assign a point
monitor to it.

1. On the Draw ribbon, click the Draw Point button .
2. In the 3D Modeler window, click the top center point of wg_outer.

Prepare and Run the Icepak Simulation 3-8
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Figure 3-11: Point Selection

3. From the right-click menu, select Assign Monitor > Point.
4. In theMonitor Setup dialog box, select Temperature and click OK. The point monitor

appears underMonitor in the Project Manager.

Figure 3-12: Project Manager - Monitor

Prepare and Run the Icepak Simulation 3-9
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Define Icepak Design Settings
Specify the project design settings as follows:

1. Click Icepak>Design Settings.

The Design Settings dialog box appears.

2. Click through the tabs and review the settings. Retain the default values on and clickOK.

Figure 3-13: Icepak Design Settings dialog box

Prepare and Run the Icepak Simulation 3-10

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak: Waveguide Filter

Add a Solution Setup
Prior to generating a mesh, you must create a solution setup, in which you specify general and
solution settings.

1. In the Project Manager, right-click on Analysis and select Add Solution Setup.
2. In the Icepak Solve Setup Dialog under Flow Regime, select Turbulent and click

Options.
3. In the Turbulent Flow Model dialog box, retain the default selection of Zero Equation

and clickOK.
4. Select Include Gravity.
5. On the Solver Settings tab, enter 1 as the Y Velocity initialization and retain the unitm_

per_sec.
6. ClickOK to save the settings. The solution setup is added under Analysis in the Project

Manager.
7. From the Filemenu, click Save.

Generate a Global Mesh
When the model geometry is finished, you can mesh the model. In this example, you'll create an
initial global mesh using the intermediate Auto Mesh Setting.

View Global Mesh Settings
1. In the Project Manager, right-click onMesh and select Edit Global Region.
2. In theMesh Region dialog box, examine the default mesh settings on theGeneral and

Advanced tabs.
3. Retain the default settings and clickOK.

Generate and Examine the Mesh
1. On the Simulation ribbon, clickGenerate Mesh. When the mesh operation is complete,

the mesh loads and theMesh visualization dialog box appears.
2. In theMesh visualization dialog box underMesh display on, select Show to display the

mesh if it is not already enabled.

3. On the View ribbon, click the Isometric orientation option from theOrient drop-down
list and then click Fit All.

Prepare and Run the Icepak Simulation 3-11
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Figure 3-14: Initial Global Mesh

4. In theMesh visualization dialog box, click theQuality tab and toggle between Face
alignment, Volume, and Skewness, noting theMin value andMax value for each. Select-
ing a histogram bar will highlight those cells in the 3D Modeler window.

Note: The following are targets value for face alignment and skewness that increase the
probability of simulation convergence and accurate results.

l Face alignment: >0.05
l Skewness: >0.02

5. Click Close to close theMesh visualization dialog box.

Generate the Refined Mesh
Edit Global Mesh Settings

1. In the Project Manager, right-click onMesh and select Edit Global Region.
2. Click and drag the Auto Mesh Setting slider bar to the finest setting (Fine/Large).
3. ClickOK.

Prepare and Run the Icepak Simulation 3-12
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Generate and Examine the Mesh
1. In the Project Manager, right-click onMesh and selectGenerate Mesh.
2. On the Simulation ribbon, clickGenerate Mesh. When the mesh operation is complete,

the mesh loads and theMesh visualization dialog box appears.
3. In theMesh visualization dialog box underMesh display on, select Show to display the

mesh if it is not already enabled.
4. In the history tree, select wg_flange_in, wg_flange_out, and wg_outer.

5. On the View ribbon, click the Isometric orientation option from theOrient and then
click Fit All.

Figure 3-15: Refined Mesh

6. In theMesh visualization dialog box, click theQuality tab and toggle between Face
alignment, Volume, and Skewness, noting theMin andMax values for each.

7. Click Close to close theMesh visualization dialog box.
8. From the Filemenu, select Save.

Prepare and Run the Icepak Simulation 3-13
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Run the Icepak Simulation
1. In the Project Manager under Analysis, right-click Setup1 and select Analyze.
2. Right-click on Setup1 again and select Residual to open the Solutions dialog box, where

you can view the solution residuals as they are updated with each iteration.

Note: You can double-click on the x-axis to open the Properties dialog box. You can
select the X Scaling tab and edit the display properties.

Figure 3-16: Solutions Dialog Box - Residual tab

3. Click the Thermal Monitor tab and review the monitor data.

Prepare and Run the Icepak Simulation 3-14
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Figure 3-17: Solutions Dialog Box - Thermal Monitor tab

4. Click the Profile tab and review the EM loss data.

Prepare and Run the Icepak Simulation 3-15
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Figure 3-18: Solutions Dialog Box - Profile tab

5. Click Close.

Prepare and Run the Icepak Simulation 3-16
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4 - Postprocess the Icepak Simulation
This chapter contains the following topic:

l Create Field Plots
l Create a Fields Summary

Create Field Plots
Create a Temperature Field Plot

1. On the View ribbon, click the Top orientation option from theOrient drop-down list
and then click Fit All.

2. In the history tree, select wg_flange_in, wg_flange_out, and wg_outer.
3. Right-click on the selection and select Plot Fields > Temperature > Temperature.
4. In the Create Field Plot dialog box, retain the default selections underQuantity and

In Volume.
5. Select the Plot on surface only check box.
6. Click Done.
7. Right-click on the Temperature legend and selectModify.
8. On the Scale tab under Number Format, select Decimal for Type and enter 6 forWidth.
9. Click Set as default and then Close.

Getting Started with Icepak: Waveguide Filter
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Figure 4-1: Temperature Field Plot

Create a Velocity Field Plot
1. In the history tree, expand Planes and selectGlobal: XY.
2. Right-click in the 3D Modeler window and select Plot Fields > Velocity > Velocity Vect-

ors.
3. In the Create Field Plot dialog box, retain all of the default selections and click Done.

Note: Click and drag the Velocity colorkey to also display the Temperature colorkey.

Figure 4-2: Velocity and Temperature Field Plots

Create a Fields Summary
Verify the energy balance using the Fields Summary report. The mapped loss is the only source
of heat for the model. For a well converged solution, the heat dissipated from the system should
be very close to the heat generated in the system.

1. On the Results ribbon, click Fields Summary.
2. In the Setup Calculation dialog box under Entity, select Inlet andOutlet.
3. UnderQuantity, select HeatFlowRate.
4. Under Side, select Adjacent.

Post process the Icepak Simulation 4-2
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Figure 4-3: Setup Calculation

5. Click the Add drop-down button and select Add as a Single Calculation.

Post process the Icepak Simulation 4-3
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Figure 4-4: Fields Summary

Note: This is the total heat convected from the waveguide filter. Note that it matches the
surface losses computed in HFSS (Fields Calculator) and the surface losses applied in
the solver (Profile Monitor).
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